{"answers":{"affected":"2 open source packages ship an affected version, including angular-ui-notification. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34840 exists.","fix":"No fix has been published for CVE-2023-34840 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-34840 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-34840 and fix it if it is affected.\n\nWhat it is: CVE-2023-34840 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34840 exists.\n\nAffected packages and fixed versions:\n- angular-ui-notification (npm): affected from 0.1.0 up to 0.3.6; no fix listed\n- angular-ui-notification (npm): affected from 0.1.0 up to 0.3.6; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34840/ (Markdown: https://insights.sbomify.com/CVE-2023-34840/index.md)","id":"CVE-2023-34840","markdown":"https://insights.sbomify.com/CVE-2023-34840/index.md","name":"CVE-2023-34840","record":{"aliases":["GHSA-mrcj-5qxr-vhp2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Angular UI notification library","requires_auth":"none","summary":"An XSS vulnerability in the angular-ui-notification library allows attackers to inject malicious scripts into web pages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"angular-ui-notification","vendor":"angular-ui-notification_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"angular-ui-notification v0.1.0, v0.2.0, and v0.3.6 was discovered to contain a cross-site scripting (XSS) vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2023-06-27","github_poc":1,"max_poc_stars":3,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-06-27T08:20:20Z","kind":"github_poc","ref":"https://github.com/Xh4H/CVE-2023-34840","stars":3,"title":"XSS in angular-ui-notification"}],"tier":"weaponised"},"has_fix":false,"headline":"angular-ui-notification Cross-site Scripting vulnerability","id":"CVE-2023-34840","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Code injection in n/a","id":"CVE-2023-34842"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0.1.0"],"last_affected":["0.3.6"],"package":"angular-ui-notification","purl":null,"source":"GHSA-mrcj-5qxr-vhp2"},{"ecosystem":"npm","fixed":[],"introduced":["0.1.0"],"last_affected":["0.3.6"],"package":"angular-ui-notification","purl":"pkg:npm/angular-ui-notification","source":"GHSA-mrcj-5qxr-vhp2"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2023-34839"},"products":["n/a"],"published":"2023-06-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["n/a"]},"summary":"An XSS vulnerability in the angular-ui-notification library allows attackers to inject malicious scripts into web pages.","url":"https://insights.sbomify.com/CVE-2023-34840/"}