{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34872 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-34872 is a medium-severity denial of service vulnerability in Freedesktop Poppler, published on 31 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-34872 and fix it if it is affected.\n\nWhat it is: CVE-2023-34872 is a medium-severity denial of service vulnerability in Freedesktop Poppler, published on 31 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-34872 in the wild and no public exploit code.\n\nAffected product: Freedesktop Poppler. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34872/ (Markdown: https://insights.sbomify.com/CVE-2023-34872/index.md)","id":"CVE-2023-34872","markdown":"https://insights.sbomify.com/CVE-2023-34872/index.md","name":"CVE-2023-34872","record":{"aliases":["BELL-CVE-2023-34872","DEBIAN-CVE-2023-34872","GHSA-77j7-vm29-rwwv","JLSEC-2026-82","MGASA-2023-0348","ROOT-OS-ALPINE-318-CVE-2023-34872","SUSE-SU-2023:4291-1","UBUNTU-CVE-2023-34872"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PDF rendering library","requires_auth":"none","summary":"A remote attacker can cause a crash in the Poppler library by providing a crafted PDF file, affecting applications that use this library for PDF rendering.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"poppler","vendor":"freedesktop"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"A vulnerability in Outline.cc for Poppler prior to 23.06.0 allows a remote attacker to cause a Denial of Service (DoS) (crash) via a crafted PDF file in OutlineItem::open.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP5","SUSE:Linux Enterprise Module for Package Hub 15 SP5","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2023-34872","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"freedesktop:poppler","products":["freedesktop:poppler"],"type":"denial_of_service","year":"2023"},"n_packages":6,"n_references":6,"next":{"headline":"Command injection in Mx6","id":"CVE-2023-34873"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP5","fixed":["23.01.0-150500.3.5.2"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/suse/poppler\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP5","source":"SUSE-SU-2023:4291-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP5","fixed":["23.01.0-150500.3.5.2"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/suse/poppler\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP5","source":"SUSE-SU-2023:4291-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP5","fixed":["23.01.0-150500.3.5.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt5","purl":"pkg:rpm/suse/poppler-qt5\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP5","source":"SUSE-SU-2023:4291-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["23.01.0-150500.3.5.2"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/opensuse/poppler\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2023:4291-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["23.01.0-150500.3.5.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt5","purl":"pkg:rpm/opensuse/poppler-qt5\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2023:4291-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["23.01.0-150500.3.5.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt6","purl":"pkg:rpm/opensuse/poppler-qt6\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2023:4291-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-34869"},"products":["n/a"],"published":"2023-07-31","related":[{"cvss_score":8.8,"headline":"Integer overflow in n/a","id":"CVE-2018-21009","kev_date_added":null,"published":"2019-09-05"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2019-12293","kev_date_added":null,"published":"2019-05-23"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2019-10872","kev_date_added":null,"published":"2019-04-05"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2019-9543","kev_date_added":null,"published":"2019-03-01"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2019-9545","kev_date_added":null,"published":"2019-03-01"},{"cvss_score":8.8,"headline":"Integer overflow in Poppler","id":"CVE-2017-2820","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":7.8,"headline":"Integer overflow in n/a","id":"CVE-2022-38171","kev_date_added":null,"published":"2022-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"A remote attacker can cause a crash in the Poppler library by providing a crafted PDF file, affecting applications that use this library for PDF rendering.","url":"https://insights.sbomify.com/CVE-2023-34872/"}