CVE-2023-3500 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Medium 4.8 Published Updated

Reflected XSS in GitLab allows attackers to perform arbitrary actions on behalf of victims via crafted PlantUML diagrams.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3500?

CVE-2023-3500 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 2 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.0 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. A reflected XSS was possible when creating specific PlantUML diagrams that allowed the attacker to perform arbitrary actions on behalf of victims.

Weakness: CWE-79

Which versions are affected by CVE-2023-3500?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.0.016.0.8, 16.1.3, 16.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-3500?

Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-3500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3500 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3500, GHSA-xgmj-r659-f4c7, UBUNTU-CVE-2023-3500.

Is CVE-2023-3500 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free