CVE-2023-35005 Apache Airflow: Information disclosure on configuration view

Medium 6.5 Published Updated

Attackers can view potentially sensitive configuration values in the UI if the expose_config setting is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-35005?

CVE-2023-35005 is a medium-severity vulnerability in Apache Airflow, published on 19 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.

This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive.

This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

Weakness: CWE-200

Which versions are affected by CVE-2023-35005?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 2.5.02.6.2
apache-airflow PyPIFrom 2.5.02.6.2rc1
apache-airflow PyPIFrom 2.5.02.6.2rc1
airflow BitnamiFrom 2.5.02.6.2

Products include Apache Airflow.

How do I fix CVE-2023-35005?

Upgrade apache-airflow to a fixed version for your release line: 2.6.2 or 2.6.2rc1.

Is CVE-2023-35005 being exploited?

There is no known exploitation of CVE-2023-35005 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2023-35005, GHSA-mjff-wv85-hmcj, PYSEC-2023-89.

Is CVE-2023-35005 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free