CVE-2023-3509 Incorrect Authorization in GitLab

Low 3.7 Published Updated

Group members with sub-maintainer roles can modify titles of private deploy keys in associated projects, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-3509?

CVE-2023-3509 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 21 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions before 16.7.6, all versions starting from 16.8 before 16.8.3, all versions starting from 16.9 before 16.9.1. It was possible for group members with sub-maintainer role to change the title of privately accessible deploy keys associated with projects in the group.

Weakness: CWE-863

Which versions are affected by CVE-2023-3509?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.7.6, 16.8.3, 16.9.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3509?

Upgrade gitlab to a fixed version for your release line: 16.7.6, 16.8.3 or 16.9.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3509 being exploited?

There is no known exploitation of CVE-2023-3509 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3509, GHSA-vwj5-wr4r-cq36, UBUNTU-CVE-2023-3509.

Is CVE-2023-3509 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free