CVE-2023-3511 Incorrect Authorization in GitLab

Low 2.0 Published Updated

Auditor users can fork and submit merge requests to private projects they are not members of, bypassing intended access controls.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-3511?

CVE-2023-3511 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 15 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 8.17 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. It was possible for auditor users to fork and submit merge requests to private projects they're not a member of.

Weakness: CWE-863

Which versions are affected by CVE-2023-3511?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.17.016.4.4, 16.5.4, 16.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-3511?

Upgrade gitlab to a fixed version for your release line: 16.4.4, 16.5.4 or 16.6.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3511 being exploited?

There is no known exploitation of CVE-2023-3511 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3511, GHSA-ghrj-rqcw-5xqp, UBUNTU-CVE-2023-3511.

Is CVE-2023-3511 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free