CVE-2023-35131 Moodle: xss risk on groups page
An attacker can inject malicious scripts into the Moodle groups page, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-35131?
CVE-2023-35131 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Content on the groups page required additional sanitizing to prevent an XSS risk. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8 and 3.11 to 3.11.14.
Weakness: CWE-79
Which versions are affected by CVE-2023-35131?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.11.15 |
moodle/moodle Packagist | All versions | 3.11.15 |
moodle/moodle Packagist | From 4.0.0 | 4.0.9 |
moodle/moodle Packagist | From 4.0.0 | 4.0.9 |
moodle/moodle Packagist | From 4.1.0 | 4.1.4 |
moodle/moodle Packagist | From 4.1.0 | 4.1.4 |
3 more packages
moodle/moodle Packagist | From 4.2.0 | 4.2.1 |
moodle/moodle Packagist | From 4.2.0 | 4.2.1 |
moodle Bitnami | From 3.11.0 | 3.11.15, 4.0.9, 4.1.4, 4.2.1 |
Products include Moodle Moodle.
How do I fix CVE-2023-35131?
Upgrade moodle/moodle to a fixed version for your release line: 3.11.15, 4.0.9, 4.1.4 or 4.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-35131 being exploited?
There is no known exploitation of CVE-2023-35131 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-35131, GHSA-fwfj-8p36-rc64, UBUNTU-CVE-2023-35131.