CVE-2023-35132 Moodle: minor sql injection risk on mnet sso access control page
An attacker can exploit a limited SQL injection vulnerability in the Mnet SSO access control page to read sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-35132?
CVE-2023-35132 is a medium-severity SQL injection vulnerability in Moodle Moodle, published on 22 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A limited SQL injection risk was identified on the Mnet SSO access control page. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.
Weakness: CWE-89
Which versions are affected by CVE-2023-35132?
11 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.22 |
moodle/moodle Packagist | All versions | 3.9.22 |
moodle/moodle Packagist | From 3.10.0 | 3.11.15 |
moodle/moodle Packagist | From 3.10.0 | 3.11.15 |
moodle/moodle Packagist | From 4.0.0 | 4.0.9 |
moodle/moodle Packagist | From 4.0.0 | 4.0.9 |
5 more packages
moodle/moodle Packagist | From 4.1.0 | 4.1.4 |
moodle/moodle Packagist | From 4.1.0 | 4.1.4 |
moodle/moodle Packagist | From 4.2.0 | 4.2.1 |
moodle/moodle Packagist | From 4.2.0 | 4.2.1 |
moodle Bitnami | All versions | 3.9.22, 3.11.15, 4.0.9, 4.1.4, 4.2.1 |
Products include Moodle Moodle.
How do I fix CVE-2023-35132?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.22, 3.11.15, 4.0.9 or 4.1.4.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2023-35132 being exploited?
There is no known exploitation of CVE-2023-35132 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-35132, GHSA-49mv-vfcp-8gg9, UBUNTU-CVE-2023-35132.