# CVE-2023-35141: Jenkins CSRF protection bypass vulnerability

> Attackers can trick victims into sending POST requests to unexpected endpoints via context menus, bypassing CSRF protections in Jenkins.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jun 2023
- **Updated:** 2 Jan 2025
- **Also known as:** BIT-jenkins-2023-35141, GHSA-98fp-r22g-wpj7

## What is CVE-2023-35141?

CVE-2023-35141 is a high-severity vulnerability in Jenkins Jenkins, published on 14 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Jenkins 2.399 and earlier, LTS 2.387.3 and earlier, POST requests are sent in order to load the list of context actions. If part of the URL includes insufficiently escaped user-provided values, a victim may be tricked into sending a POST request to an unexpected endpoint by opening a context menu.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-35141?

3 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.400 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.400 |
| `jenkins` | Bitnami | All versions | 2.401.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2023-35141?

Upgrade org.jenkins-ci.main:jenkins-core to 2.400 or later.

## Is CVE-2023-35141 being exploited?

There is no known exploitation of CVE-2023-35141 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35141 and fix it if it is affected.

What it is: CVE-2023-35141 is a high-severity vulnerability in Jenkins Jenkins, published on 14 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-35141 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.400
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.400
- jenkins (Bitnami): affected all versions; fixed in 2.401.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35141/ (Markdown: https://insights.sbomify.com/CVE-2023-35141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35141
- OSV: https://osv.dev/vulnerability/CVE-2023-35141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35141/
Summaries are generated and may contain mistakes; the official description above is the record.
