# CVE-2023-35142: SSL/TLS certificate validation disabled by default in Jenkins Checkmarx Plugin

> The Jenkins Checkmarx Plugin disables SSL/TLS validation by default, allowing attackers to intercept or manipulate traffic between Jenkins and the Checkmarx server.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2023
- **Updated:** 2 Jan 2025
- **Also known as:** GHSA-rr3p-5fcf-v5m3

## What is CVE-2023-35142?

CVE-2023-35142 is a high-severity vulnerability in Jenkins Checkmarx Plugin, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Checkmarx Plugin 2022.4.3 and earlier disables SSL/TLS validation for connections to the Checkmarx server by default.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2023-35142?

2 open source packages ship an affected version, including com.checkmarx.jenkins:checkmarx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.checkmarx.jenkins:checkmarx` | Maven | All versions | 2023.2.6 |
| `com.checkmarx.jenkins:checkmarx` | Maven | All versions | 2023.2.6 |

Products: Jenkins Checkmarx.

## How do I fix CVE-2023-35142?

Upgrade com.checkmarx.jenkins:checkmarx to 2023.2.6 or later.

## Is CVE-2023-35142 being exploited?

There is no known exploitation of CVE-2023-35142 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Checkmarx Plugin

- [CVE-2022-25200](https://insights.sbomify.com/CVE-2022-25200/): CSRF vulnerability in Jenkins Checkmarx Plugin allow capturing credentials (high 8.8)
- [CVE-2022-25201](https://insights.sbomify.com/CVE-2022-25201/): Missing permission checks in Jenkins Checkmarx Plugin allow capturing credentials (medium 6.5)
- [CVE-2022-46684](https://insights.sbomify.com/CVE-2022-46684/): Stored XSS vulnerability in Jenkins Checkmarx Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35142 and fix it if it is affected.

What it is: CVE-2023-35142 is a high-severity vulnerability in Jenkins Checkmarx Plugin, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35142 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.checkmarx.jenkins:checkmarx (Maven): affected all versions; fixed in 2023.2.6
- com.checkmarx.jenkins:checkmarx (Maven): affected all versions; fixed in 2023.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35142/ (Markdown: https://insights.sbomify.com/CVE-2023-35142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35142
- OSV: https://osv.dev/vulnerability/CVE-2023-35142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35142/
Summaries are generated and may contain mistakes; the official description above is the record.
