CVE-2023-35150 XWiki Platform vulnerable to privilege escalation (PR) from view right via Invitation application
Attackers with view rights can execute arbitrary code with programming rights via crafted URLs, leading to remote code execution and privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-35150?
CVE-2023-35150 is a critical code injection vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 2.40m-2 and prior to versions 14.4.8, 14.10.4, and 15.0, any user with view rights on any document can execute code with programming rights, leading to remote code execution by crafting an url with a dangerous payload. The problem has been patched in XWiki 15.0, 14.10.4 and 14.4.8.
Which versions are affected by CVE-2023-35150?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-invitation-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-invitation-ui Maven | From 14.5 | 14.10.4 |
org.xwiki.platform:xwiki-platform-invitation-ui Maven | From 14.5 | 14.10.4 |
org.xwiki.platform:xwiki-platform-invitation-ui Maven | From 15.0-rc-1 | 15.0 |
org.xwiki.platform:xwiki-platform-invitation-ui Maven | From 15.0-rc-1 | 15.0 |
org.xwiki.platform:xwiki-platform-invitation-ui Maven | From 2.4-m-2 | 14.4.8 |
org.xwiki.platform:xwiki-platform-invitation-ui Maven | From 2.4-m-2 | 14.4.8 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-35150?
Upgrade org.xwiki.platform:xwiki-platform-invitation-ui to a fixed version for your release line: 14.10.4, 15.0 or 14.4.8.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-35150 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35150 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-6mf5-36v9-3h2w.