# CVE-2023-35157: XWiki Platform vulnerable to reflected cross-site scripting via delattachment action

> Attackers can execute arbitrary scripts in victim browsers via a crafted delete attachment request, potentially leading to session hijacking or data theft.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 27 Nov 2024
- **Also known as:** GHSA-phwm-87rg-27qq

## What is CVE-2023-35157?

CVE-2023-35157 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible to perform an XSS by forging a request to a delete attachment action with a specific attachment name. Now this XSS can be exploited only if the attacker knows the CSRF token of the user, or if the user ignores the warning about the missing CSRF token. The vulnerability has been patched in XWiki 15.1-rc-1 and XWiki 14.10.6.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-35157?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-0 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-0 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 3.2-milestone-3 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 3.2-milestone-3 | 14.10.6 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-35157?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.1-rc-1 or 14.10.6.

## Is CVE-2023-35157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35157 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35157 and fix it if it is affected.

What it is: CVE-2023-35157 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35157 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-0; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-0; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 3.2-milestone-3; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 3.2-milestone-3; fixed in 14.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35157/ (Markdown: https://insights.sbomify.com/CVE-2023-35157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35157
- OSV: https://osv.dev/vulnerability/CVE-2023-35157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35157/
Summaries are generated and may contain mistakes; the official description above is the record.
