# CVE-2023-35159: XWiki Platform vulnerable to reflected cross-site scripting via xredirect parameter in deletespace template

> Attackers can inject JavaScript via the xredirect parameter in the deletespace template, potentially executing arbitrary code in victim browsers.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 27 Nov 2024
- **Also known as:** GHSA-x234-mg7q-m8g8

## What is CVE-2023-35159?

CVE-2023-35159 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Users are able to forge an URL with a payload allowing to inject Javascript in the page (XSS). It's possible to exploit the deletespace template to perform a XSS, e.g. by using URL such as: > xwiki/bin/deletespace/Sandbox/?xredirect=javascript:alert(document.domain). This vulnerability exists since XWiki 3.4-milestone-1. The vulnerability has been patched in XWiki 14.10.5 and 15.1-rc-1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-87 (Improper Neutralization of Alternate XSS Syntax)

## Which versions are affected by CVE-2023-35159?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 3.4-milestone-1 | 14.10.5 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 3.4-milestone-1 | 14.10.5 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-35159?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 15.1-rc-1 or 14.10.5.

## Is CVE-2023-35159 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35159 exists.

Public exploit code:

- XWiki >= 3.4-milestone-1 - Cross-Site Scripting (nuclei): http/cves/2023/CVE-2023-35159.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35159 and fix it if it is affected.

What it is: CVE-2023-35159 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35159 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 3.4-milestone-1; fixed in 14.10.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 3.4-milestone-1; fixed in 14.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35159/ (Markdown: https://insights.sbomify.com/CVE-2023-35159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35159
- OSV: https://osv.dev/vulnerability/CVE-2023-35159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35159/
Summaries are generated and may contain mistakes; the official description above is the record.
