CVE-2023-35165 AWS CDK EKS overly permissive trust policies
AWS CDK EKS constructs create overly permissive IAM trust policies, allowing unauthorized privilege escalation and cluster access.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-35165?
CVE-2023-35165 is a medium-severity vulnerability in aws-cdk, published on 23 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
AWS Cloud Development Kit (AWS CDK) is an open-source software development framework to define cloud infrastructure in code and provision it through AWS CloudFormation. In the packages `aws-cdk-lib` 2.0.0 until 2.80.0 and `@aws-cdk/aws-eks` 1.57.0 until 1.202.0, `eks.Cluster` and `eks.FargateCluster` constructs create two roles, `CreationRole` and `default MastersRole`, that have an overly permissive trust policy. The first, referred to as the `CreationRole`, is used by lambda handlers to create the cluster and deploy Kubernetes resources (e.g `KubernetesManifest`, `HelmChart`, ...) onto it. Users with CDK version higher or equal to 1.62.0 (including v2 users) may be affected. The second, referred to as the `default MastersRole`, is provisioned only if the `mastersRole` property isn't provided and has permissions to execute `kubectl` commands on the cluster. Users with CDK version higher or equal to 1.57.0 (including v2 users) may be affected.
The issue has been fixed in `@aws-cdk/aws-eks` v1.202.0 and `aws-cdk-lib` v2.80.0. These versions no longer use the account root principal. Instead, they restrict the trust policy to the specific roles of lambda handlers that need it. There is no workaround available for CreationRole. To avoid creating the `default MastersRole`, use the `mastersRole` property to explicitly provide a role.
Weakness: CWE-863
Which versions are affected by CVE-2023-35165?
4 open source packages ship an affected version, including @aws-cdk/aws-eks and aws-cdk-lib. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@aws-cdk/aws-eks npm | From 1.57.0 | 1.202.0 |
@aws-cdk/aws-eks npm | From 1.57.0 | 1.202.0 |
aws-cdk-lib npm | From 2.0.0 | 2.80.0 |
aws-cdk-lib npm | From 2.0.0 | 2.80.0 |
Products include Amazon Aws Cloud Development Kit.
How do I fix CVE-2023-35165?
Upgrade @aws-cdk/aws-eks to 1.202.0 or later.
Is CVE-2023-35165 being exploited?
There is no known exploitation of CVE-2023-35165 in the wild and no public exploit code.
Other vulnerabilities in aws-cdk
Sources
Also known as GHSA-rx28-r23p-2qc3.