# CVE-2023-35165: AWS CDK EKS overly permissive trust policies

> AWS CDK EKS constructs create overly permissive IAM trust policies, allowing unauthorized privilege escalation and cluster access.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 5 Dec 2024
- **Also known as:** GHSA-rx28-r23p-2qc3

## What is CVE-2023-35165?

CVE-2023-35165 is a medium-severity vulnerability in aws-cdk, published on 23 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

AWS Cloud Development Kit (AWS CDK) is an open-source software development framework to define cloud infrastructure in code and provision it through AWS CloudFormation. In the packages `aws-cdk-lib` 2.0.0 until 2.80.0 and `@aws-cdk/aws-eks` 1.57.0 until 1.202.0, `eks.Cluster` and `eks.FargateCluster` constructs create two roles, `CreationRole` and `default MastersRole`, that have an overly permissive trust policy. 
 
The first, referred to as the `CreationRole`, is used by lambda handlers to create the cluster and deploy Kubernetes resources (e.g `KubernetesManifest`, `HelmChart`, ...) onto it. Users with CDK version higher or equal to 1.62.0 (including v2 users) may be affected.
 
The second, referred to as the `default MastersRole`, is provisioned only if the `mastersRole` property isn't provided and has permissions to execute `kubectl` commands on the cluster. Users with CDK version higher or equal to 1.57.0 (including v2 users) may be affected.

The issue has been fixed in `@aws-cdk/aws-eks` v1.202.0 and `aws-cdk-lib` v2.80.0. These versions no longer use the account root principal. Instead, they restrict the trust policy to the specific roles of lambda handlers that need it. There is no workaround available for CreationRole. To avoid creating the `default MastersRole`, use the `mastersRole` property to explicitly provide a role.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-35165?

4 open source packages ship an affected version, including @aws-cdk/aws-eks and aws-cdk-lib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@aws-cdk/aws-eks` | npm | From 1.57.0 | 1.202.0 |
| `@aws-cdk/aws-eks` | npm | From 1.57.0 | 1.202.0 |
| `aws-cdk-lib` | npm | From 2.0.0 | 2.80.0 |
| `aws-cdk-lib` | npm | From 2.0.0 | 2.80.0 |

Products: Amazon Aws Cloud Development Kit.

## How do I fix CVE-2023-35165?

Upgrade @aws-cdk/aws-eks to 1.202.0 or later.

## Is CVE-2023-35165 being exploited?

There is no known exploitation of CVE-2023-35165 in the wild and no public exploit code.

## Other vulnerabilities in aws-cdk

- [CVE-2024-45037](https://insights.sbomify.com/CVE-2024-45037/): AWS CDK RestApi not generating authorizationScope correctly in resultant CFN template (medium 6.4)
- [CVE-2025-2598](https://insights.sbomify.com/CVE-2025-2598/): AWS CDK CLI prints AWS credentials retrieved by custom credential plugins (medium 5.7)
- [CVE-2025-23206](https://insights.sbomify.com/CVE-2025-23206/): IAM OIDC custom resource allows connection to unauthorized OIDC provider in aws-cdk (low 1.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35165 and fix it if it is affected.

What it is: CVE-2023-35165 is a medium-severity vulnerability in aws-cdk, published on 23 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35165 in the wild and no public exploit code.

Affected packages and fixed versions:
- @aws-cdk/aws-eks (npm): affected from 1.57.0; fixed in 1.202.0
- @aws-cdk/aws-eks (npm): affected from 1.57.0; fixed in 1.202.0
- aws-cdk-lib (npm): affected from 2.0.0; fixed in 2.80.0
- aws-cdk-lib (npm): affected from 2.0.0; fixed in 2.80.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35165/ (Markdown: https://insights.sbomify.com/CVE-2023-35165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35165
- OSV: https://osv.dev/vulnerability/CVE-2023-35165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35165/
Summaries are generated and may contain mistakes; the official description above is the record.
