# CVE-2023-35166: Privilege escalation (PR) from account through TipsPanel

> Attackers can execute arbitrary wiki content with TipsPanel author privileges, leading to privilege escalation and code execution in XWiki Platform.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2023
- **Updated:** 6 Dec 2024
- **Also known as:** GHSA-h7cw-44vp-jq7h

## What is CVE-2023-35166?

CVE-2023-35166 is a critical vulnerability in Xwiki Xwiki, published on 20 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible to execute any wiki content with the right of the TipsPanel author by creating a tip UI extension. This has been patched in XWiki 15.1-rc-1 and 14.10.5.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-35166?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-help-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-help-ui` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-help-ui` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-help-ui` | Maven | From 8.1-milestone-1 | 14.10.5 |
| `org.xwiki.platform:xwiki-platform-help-ui` | Maven | From 8.1-milestone-1 | 14.10.5 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-35166?

Upgrade org.xwiki.platform:xwiki-platform-help-ui to a fixed version for your release line: 15.1-rc-1 or 14.10.5.

## Is CVE-2023-35166 being exploited?

There is no known exploitation of CVE-2023-35166 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35166 and fix it if it is affected.

What it is: CVE-2023-35166 is a critical vulnerability in Xwiki Xwiki, published on 20 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35166 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-help-ui (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-help-ui (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-help-ui (Maven): affected from 8.1-milestone-1; fixed in 14.10.5
- org.xwiki.platform:xwiki-platform-help-ui (Maven): affected from 8.1-milestone-1; fixed in 14.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35166/ (Markdown: https://insights.sbomify.com/CVE-2023-35166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35166
- OSV: https://osv.dev/vulnerability/CVE-2023-35166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35166/
Summaries are generated and may contain mistakes; the official description above is the record.
