# CVE-2023-35167: When setting EntityOptions.apiPrefilter to a function, the filter is not applied to API requests for a resource by Id

> Attackers can bypass API filters to read, update, or delete unauthorized data by ID if apiPrefilter is set to a function.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-7hh3-3x64-v2g9

## What is CVE-2023-35167?

CVE-2023-35167 is a medium-severity missing authorization vulnerability in remult, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Remult is a CRUD framework for full-stack TypeScript. If you used the apiPrefilter option of the `@Entity` decorator, by setting it to a function that returns a filter that prevents unauthorized access to data, an attacker who knows the `id` of an entity instance is not authorized to access, can gain read, update and delete access to it. The issue is fixed in version 0.20.6. As a workaround, set the `apiPrefilter` option to a filter object instead of a function.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-35167?

2 open source packages ship an affected version, including remult. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remult` | npm | All versions | 0.20.6 |
| `remult` | npm | All versions | 0.20.6 |

Products: Remult Remult.

## How do I fix CVE-2023-35167?

Upgrade remult to 0.20.6 or later.

## Is CVE-2023-35167 being exploited?

There is no known exploitation of CVE-2023-35167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35167 and fix it if it is affected.

What it is: CVE-2023-35167 is a medium-severity missing authorization vulnerability in remult, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35167 in the wild and no public exploit code.

Affected packages and fixed versions:
- remult (npm): affected all versions; fixed in 0.20.6
- remult (npm): affected all versions; fixed in 0.20.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35167/ (Markdown: https://insights.sbomify.com/CVE-2023-35167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35167
- OSV: https://osv.dev/vulnerability/CVE-2023-35167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35167/
Summaries are generated and may contain mistakes; the official description above is the record.
