# CVE-2023-3518: JWT Auth in L7 Intentions Allow For Mismatched Service Identity and JWT Providers for Access

> Attackers can bypass service identity checks in Consul's JWT authentication, gaining unauthorized access to services.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2023
- **Updated:** 8 Oct 2024
- **Also known as:** BIT-consul-2023-3518, GHSA-9rhf-q362-77mx, GO-2024-2704

## What is CVE-2023-3518?

CVE-2023-3518 is a high-severity authentication bypass vulnerability in HashiCorp Consul, published on 9 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Consul and Consul Enterprise 1.16.0 when using JWT Auth for service mesh incorrectly allows/denies access regardless of service identities. Fixed in 1.16.1.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2023-3518?

4 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | From 1.16.0 | 1.16.1 |
| `github.com/hashicorp/consul` | Go | From 1.16.0 | 1.16.1 |
| `github.com/hashicorp/consul` | Go | From 1.16.0 | 1.16.1 |
| `consul` | Bitnami | From 1.16.0 | 1.16.1 |

Products: Hashicorp Consul.

## How do I fix CVE-2023-3518?

Upgrade github.com/hashicorp/consul to 1.16.1 or later.

## Is CVE-2023-3518 being exploited?

There is no known exploitation of CVE-2023-3518 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Consul

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3518 and fix it if it is affected.

What it is: CVE-2023-3518 is a high-severity authentication bypass vulnerability in HashiCorp Consul, published on 9 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3518 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected from 1.16.0; fixed in 1.16.1
- github.com/hashicorp/consul (Go): affected from 1.16.0; fixed in 1.16.1
- github.com/hashicorp/consul (Go): affected from 1.16.0; fixed in 1.16.1
- consul (Bitnami): affected from 1.16.0; fixed in 1.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3518/ (Markdown: https://insights.sbomify.com/CVE-2023-3518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3518
- OSV: https://osv.dev/vulnerability/CVE-2023-3518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3518/
Summaries are generated and may contain mistakes; the official description above is the record.
