{"answers":{"affected":"2 open source packages ship an affected version, including mediawiki and mediawiki/core. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3550 exists.","fix":"Upgrade mediawiki to 1.40.1 or later.","what":"CVE-2023-3550 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-3550 and fix it if it is affected.\n\nWhat it is: CVE-2023-3550 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3550 exists.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected from 1.40.0; fixed in 1.40.1\n- mediawiki/core (Packagist): affected all versions up to 1.40.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3550/ (Markdown: https://insights.sbomify.com/CVE-2023-3550/index.md)","id":"CVE-2023-3550","markdown":"https://insights.sbomify.com/CVE-2023-3550/index.md","name":"CVE-2023-3550","record":{"aliases":["BIT-mediawiki-2023-3550","DEBIAN-CVE-2023-3550","GHSA-4pqg-hr8r-h5cw","UBUNTU-CVE-2023-3550"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"MediaWiki","requires_auth":"low_privilege","summary":"A stored XSS vulnerability in MediaWiki allows low-privileged users to escalate privileges to administrator if XML uploads are enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Fluid Attacks","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mediawiki v1.40.0 does not validate namespaces used in XML files.\n\nTherefore, if the instance administrator allows XML file uploads,\n\na remote attacker with a low-privileged user account can use this\n\nexploit to become an administrator by sending a malicious link to\n\nthe instance administrator.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Stored XSS leads to privilege escalation in MediaWiki v1.40.0","id":"CVE-2023-3550","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","mediawiki:mediawiki"],"type":"xss","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"Code Injection in nilsteampassnet/teampass","id":"CVE-2023-3551"},"packages":[{"ecosystem":"Bitnami","fixed":["1.40.1"],"introduced":["1.40.0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2023-3550"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.40.0"],"package":"mediawiki/core","purl":null,"source":"GHSA-4pqg-hr8r-h5cw"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2023-3549"},"products":["MediaWiki"],"published":"2023-09-25","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["MediaWiki"]},"summary":"A stored XSS vulnerability in MediaWiki allows low-privileged users to escalate privileges to administrator if XML uploads are enabled.","url":"https://insights.sbomify.com/CVE-2023-3550/"}