# CVE-2023-3550: Stored XSS leads to privilege escalation in MediaWiki v1.40.0

> A stored XSS vulnerability in MediaWiki allows low-privileged users to escalate privileges to administrator if XML uploads are enabled.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-mediawiki-2023-3550, DEBIAN-CVE-2023-3550, GHSA-4pqg-hr8r-h5cw, UBUNTU-CVE-2023-3550

## What is CVE-2023-3550?

CVE-2023-3550 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mediawiki v1.40.0 does not validate namespaces used in XML files.

Therefore, if the instance administrator allows XML file uploads,

a remote attacker with a low-privileged user account can use this

exploit to become an administrator by sending a malicious link to

the instance administrator.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-3550?

2 open source packages ship an affected version, including mediawiki and mediawiki/core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | From 1.40.0 | 1.40.1 |
| `mediawiki/core` | Packagist | All versions to 1.40.0 | None |

Products: Debian Debian Linux, Mediawiki Mediawiki.

## How do I fix CVE-2023-3550?

Upgrade mediawiki to 1.40.1 or later.

## Is CVE-2023-3550 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3550 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3550 and fix it if it is affected.

What it is: CVE-2023-3550 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3550 exists.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected from 1.40.0; fixed in 1.40.1
- mediawiki/core (Packagist): affected all versions up to 1.40.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3550/ (Markdown: https://insights.sbomify.com/CVE-2023-3550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3550
- OSV: https://osv.dev/vulnerability/CVE-2023-3550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3550/
Summaries are generated and may contain mistakes; the official description above is the record.
