CVE-2023-35783 ke_search (aka Faceted Search) vulnerable to Cross-Site Scripting
Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts via indexed data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-35783?
CVE-2023-35783 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The ke_search (aka Faceted Search) extension before 4.0.3, 4.1.x through 4.6.x before 4.6.6, and 5.x before 5.0.2 for TYPO3 allows XSS via indexed data.
Weakness: CWE-79
Which versions are affected by CVE-2023-35783?
6 open source packages ship an affected version, including tpwd/ke_search. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tpwd/ke_search Packagist | All versions | 4.0.3 |
tpwd/ke_search Packagist | All versions | 4.0.3 |
tpwd/ke_search Packagist | From 4.1.0 | 4.6.6 |
tpwd/ke_search Packagist | From 4.1.0 | 4.6.6 |
tpwd/ke_search Packagist | From 5.0.0 | 5.0.2 |
tpwd/ke_search Packagist | From 5.0.0 | 5.0.2 |
Products include Faceted Search Project Faceted Search.
How do I fix CVE-2023-35783?
Upgrade tpwd/ke_search to a fixed version for your release line: 4.0.3, 4.6.6 or 5.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-35783 being exploited?
There is no known exploitation of CVE-2023-35783 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-f4m6-x2xj-jc7w.