{"answers":{"affected":"6 open source packages ship an affected version, including tpwd/ke_search. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-35783 in the wild and no public exploit code.","fix":"Upgrade tpwd/ke_search to a fixed version for your release line: 4.0.3, 4.6.6 or 5.0.2.","what":"CVE-2023-35783 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-35783 and fix it if it is affected.\n\nWhat it is: CVE-2023-35783 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-35783 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tpwd/ke_search (Packagist): affected all versions; fixed in 4.0.3\n- tpwd/ke_search (Packagist): affected all versions; fixed in 4.0.3\n- tpwd/ke_search (Packagist): affected from 4.1.0; fixed in 4.6.6\n- tpwd/ke_search (Packagist): affected from 4.1.0; fixed in 4.6.6\n- tpwd/ke_search (Packagist): affected from 5.0.0; fixed in 5.0.2\n- tpwd/ke_search (Packagist): affected from 5.0.0; fixed in 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-35783/ (Markdown: https://insights.sbomify.com/CVE-2023-35783/index.md)","id":"CVE-2023-35783","markdown":"https://insights.sbomify.com/CVE-2023-35783/index.md","name":"CVE-2023-35783","record":{"aliases":["GHSA-f4m6-x2xj-jc7w"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 extension","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts via indexed data.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"faceted_search","vendor":"faceted_search_project"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AC:L/AV:N/A:L/C:L/I:L/PR:L/S:U/UI:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The ke_search (aka Faceted Search) extension before 4.0.3, 4.1.x through 4.6.x before 4.6.6, and 5.x before 5.0.2 for TYPO3 allows XSS via indexed data.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ke_search (aka Faceted Search) vulnerable to Cross-Site Scripting","id":"CVE-2023-35783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":6,"n_references":1,"next":{"headline":"Use after free in n/a","id":"CVE-2023-35784"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"tpwd/ke_search","purl":null,"source":"GHSA-f4m6-x2xj-jc7w"},{"ecosystem":"Packagist","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"tpwd/ke_search","purl":"pkg:composer/tpwd/ke_search","source":"GHSA-f4m6-x2xj-jc7w"},{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["4.1.0"],"last_affected":[],"package":"tpwd/ke_search","purl":null,"source":"GHSA-f4m6-x2xj-jc7w"},{"ecosystem":"Packagist","fixed":["4.6.6"],"introduced":["4.1.0"],"last_affected":[],"package":"tpwd/ke_search","purl":"pkg:composer/tpwd/ke_search","source":"GHSA-f4m6-x2xj-jc7w"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["5.0.0"],"last_affected":[],"package":"tpwd/ke_search","purl":null,"source":"GHSA-f4m6-x2xj-jc7w"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["5.0.0"],"last_affected":[],"package":"tpwd/ke_search","purl":"pkg:composer/tpwd/ke_search","source":"GHSA-f4m6-x2xj-jc7w"}],"prev":{"headline":"ipandlanguageredirect extension vulnerable to SQL Injection","id":"CVE-2023-35782"},"products":["n/a"],"published":"2023-06-16","related":[{"cvss_score":5.4,"headline":"ke_search for Typo3 XSS Vulnerability","id":"CVE-2020-15517","kev_date_added":null,"published":"2020-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-11","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts via indexed data.","url":"https://insights.sbomify.com/CVE-2023-35783/"}