{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-apache-hive. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-35797 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-hive to 6.1.1 or later.","what":"CVE-2023-35797 is a critical command injection vulnerability in Apache Airflow Apache Hive Provider, published on 3 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-35797 and fix it if it is affected.\n\nWhat it is: CVE-2023-35797 is a critical command injection vulnerability in Apache Airflow Apache Hive Provider, published on 3 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-35797 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.1.1\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.1.1\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-35797/ (Markdown: https://insights.sbomify.com/CVE-2023-35797/index.md)","id":"CVE-2023-35797","markdown":"https://insights.sbomify.com/CVE-2023-35797/index.md","name":"CVE-2023-35797","record":{"aliases":["GHSA-hg6c-qqcm-r79r","PYSEC-2026-273"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow Hive Provider","requires_auth":"none","summary":"Attackers with connection modification access can achieve remote code execution in Apache Airflow Hive Provider by bypassing security checks on the principal parameter.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-apache-hive","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider.\nThis issue affects Apache Airflow Apache Hive Provider: before 6.1.1.\n\nBefore version 6.1.1 it was possible to bypass the security check to RCE via\nprincipal parameter. For this to be exploited it requires access to modifying the connection details.\n\nIt is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Hive Provider Beeline RCE with Principal","id":"CVE-2023-35797","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Airflow Apache ODBC and MSSQL Providers Arbitrary File Read Vulnerability","id":"CVE-2023-35798"},"packages":[{"ecosystem":"PyPI","fixed":["6.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":null,"source":"GHSA-hg6c-qqcm-r79r"},{"ecosystem":"PyPI","fixed":["6.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":"pkg:pypi/apache-airflow-providers-apache-hive","source":"GHSA-hg6c-qqcm-r79r"},{"ecosystem":"PyPI","fixed":["6.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":"pkg:pypi/apache-airflow-providers-apache-hive","source":"PYSEC-2026-273"}],"prev":{"headline":"Cross-site scripting in SINEMA Server V14","id":"CVE-2023-35796"},"products":["Apache Airflow Apache Hive Provider"],"published":"2023-07-03","related":[{"cvss_score":9.8,"headline":"Apache Airflow Hive Provider Beeline RCE","id":"CVE-2023-25696","kev_date_added":null,"published":"2023-02-24"},{"cvss_score":9.8,"headline":"Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params","id":"CVE-2022-46421","kev_date_added":null,"published":"2022-12-20"},{"cvss_score":8.8,"headline":"Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user","id":"CVE-2023-37415","kev_date_added":null,"published":"2023-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers with connection modification access can achieve remote code execution in Apache Airflow Hive Provider by bypassing security checks on the principal parameter.","url":"https://insights.sbomify.com/CVE-2023-35797/"}