# CVE-2023-35797: Apache Airflow Hive Provider Beeline RCE with Principal

> Attackers with connection modification access can achieve remote code execution in Apache Airflow Hive Provider by bypassing security checks on the principal parameter.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-hg6c-qqcm-r79r, PYSEC-2026-273

## What is CVE-2023-35797?

CVE-2023-35797 is a critical command injection vulnerability in Apache Airflow Apache Hive Provider, published on 3 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider.
This issue affects Apache Airflow Apache Hive Provider: before 6.1.1.

Before version 6.1.1 it was possible to bypass the security check to RCE via
principal parameter. For this to be exploited it requires access to modifying the connection details.

It is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-35797?

3 open source packages ship an affected version, including apache-airflow-providers-apache-hive. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 6.1.1 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 6.1.1 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 6.1.1 |

Products: Apache Apache-Airflow-Providers-Apache-Hive.

## How do I fix CVE-2023-35797?

Upgrade apache-airflow-providers-apache-hive to 6.1.1 or later.

## Is CVE-2023-35797 being exploited?

There is no known exploitation of CVE-2023-35797 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Apache Hive Provider

- [CVE-2023-25696](https://insights.sbomify.com/CVE-2023-25696/): Apache Airflow Hive Provider Beeline RCE (critical 9.8)
- [CVE-2022-46421](https://insights.sbomify.com/CVE-2022-46421/): Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params (critical 9.8)
- [CVE-2023-37415](https://insights.sbomify.com/CVE-2023-37415/): Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35797 and fix it if it is affected.

What it is: CVE-2023-35797 is a critical command injection vulnerability in Apache Airflow Apache Hive Provider, published on 3 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35797 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.1.1
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.1.1
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35797/ (Markdown: https://insights.sbomify.com/CVE-2023-35797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35797
- OSV: https://osv.dev/vulnerability/CVE-2023-35797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35797/
Summaries are generated and may contain mistakes; the official description above is the record.
