{"answers":{"affected":"4 open source packages ship an affected version, including com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit and com.fastasyncworldedit:FastAsyncWorldEdit-Core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35925 exists.","fix":"Upgrade com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit to 2.6.3 or later.","what":"CVE-2023-35925 is a medium-severity denial of service vulnerability in IntellectualSites FastAsyncWorldEdit, published on 23 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-35925 and fix it if it is affected.\n\nWhat it is: CVE-2023-35925 is a medium-severity denial of service vulnerability in IntellectualSites FastAsyncWorldEdit, published on 23 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35925 exists.\n\nAffected packages and fixed versions:\n- com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit (Maven): affected all versions; fixed in 2.6.3\n- com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit (Maven): affected all versions; fixed in 2.6.3\n- com.fastasyncworldedit:FastAsyncWorldEdit-Core (Maven): affected all versions; fixed in 2.6.3\n- com.fastasyncworldedit:FastAsyncWorldEdit-Core (Maven): affected all versions; fixed in 2.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-35925/ (Markdown: https://insights.sbomify.com/CVE-2023-35925/index.md)","id":"CVE-2023-35925","markdown":"https://insights.sbomify.com/CVE-2023-35925/index.md","name":"CVE-2023-35925","record":{"aliases":["GHSA-whj9-m24x-qhhp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Minecraft world editor","requires_auth":"none","summary":"Attackers can crash the server by selecting an infinite region in FastAsyncWorldEdit, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastasyncworldedit","vendor":"intellectualsites"}],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"FastAsyncWorldEdit (FAWE) is designed for efficient world editing. This vulnerability enables the attacker to select a region with the `Infinity` keyword (case-sensitive!) and executes any operation. This has a possibility of bringing the performing server down. This issue has been fixed in version 2.6.3.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FastAsyncWorldEdit vulnerable to Uncontrolled Resource Consumption","id":"CVE-2023-35925","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Insecure sandbox in Backstage Scaffolder plugin","id":"CVE-2023-35926"},"packages":[{"ecosystem":"Maven","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit","purl":null,"source":"GHSA-whj9-m24x-qhhp"},{"ecosystem":"Maven","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit","purl":"pkg:maven/com.fastasyncworldedit/FastAsyncWorldEdit-Bukkit","source":"GHSA-whj9-m24x-qhhp"},{"ecosystem":"Maven","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"com.fastasyncworldedit:FastAsyncWorldEdit-Core","purl":null,"source":"GHSA-whj9-m24x-qhhp"},{"ecosystem":"Maven","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"com.fastasyncworldedit:FastAsyncWorldEdit-Core","purl":"pkg:maven/com.fastasyncworldedit/FastAsyncWorldEdit-Core","source":"GHSA-whj9-m24x-qhhp"}],"prev":{"headline":"GLPI vulnerable to SQL injection via inventory agent request","id":"CVE-2023-35924"},"products":["FastAsyncWorldEdit"],"published":"2023-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-27","vendors":["IntellectualSites"]},"summary":"Attackers can crash the server by selecting an infinite region in FastAsyncWorldEdit, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-35925/"}