# CVE-2023-35925: FastAsyncWorldEdit vulnerable to Uncontrolled Resource Consumption

> Attackers can crash the server by selecting an infinite region in FastAsyncWorldEdit, requiring an upgrade to the latest version.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 27 Nov 2024
- **Also known as:** GHSA-whj9-m24x-qhhp

## What is CVE-2023-35925?

CVE-2023-35925 is a medium-severity denial of service vulnerability in IntellectualSites FastAsyncWorldEdit, published on 23 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

FastAsyncWorldEdit (FAWE) is designed for efficient world editing. This vulnerability enables the attacker to select a region with the `Infinity` keyword (case-sensitive!) and executes any operation. This has a possibility of bringing the performing server down. This issue has been fixed in version 2.6.3.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-35925?

4 open source packages ship an affected version, including com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit and com.fastasyncworldedit:FastAsyncWorldEdit-Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit` | Maven | All versions | 2.6.3 |
| `com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit` | Maven | All versions | 2.6.3 |
| `com.fastasyncworldedit:FastAsyncWorldEdit-Core` | Maven | All versions | 2.6.3 |
| `com.fastasyncworldedit:FastAsyncWorldEdit-Core` | Maven | All versions | 2.6.3 |

Products: Intellectualsites Fastasyncworldedit.

## How do I fix CVE-2023-35925?

Upgrade com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit to 2.6.3 or later.

## Is CVE-2023-35925 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35925 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35925 and fix it if it is affected.

What it is: CVE-2023-35925 is a medium-severity denial of service vulnerability in IntellectualSites FastAsyncWorldEdit, published on 23 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35925 exists.

Affected packages and fixed versions:
- com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit (Maven): affected all versions; fixed in 2.6.3
- com.fastasyncworldedit:FastAsyncWorldEdit-Bukkit (Maven): affected all versions; fixed in 2.6.3
- com.fastasyncworldedit:FastAsyncWorldEdit-Core (Maven): affected all versions; fixed in 2.6.3
- com.fastasyncworldedit:FastAsyncWorldEdit-Core (Maven): affected all versions; fixed in 2.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35925/ (Markdown: https://insights.sbomify.com/CVE-2023-35925/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35925
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35925
- OSV: https://osv.dev/vulnerability/CVE-2023-35925

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35925/
Summaries are generated and may contain mistakes; the official description above is the record.
