# CVE-2023-35926: Insecure sandbox in Backstage Scaffolder plugin

> A malicious actor with write access to a scaffolder template can achieve remote code execution on the backend due to an insecure sandbox implementation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2023
- **Updated:** 5 Dec 2024
- **Also known as:** GHSA-wg6p-jmpc-xjmr

## What is CVE-2023-35926?

CVE-2023-35926 is a high-severity code injection vulnerability in Linuxfoundation Backstage, published on 22 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Backstage is an open platform for building developer portals. The Backstage scaffolder-backend plugin uses a templating library that requires sandbox, as it by design allows for code injection. The library used for this sandbox so far has been `vm2`, but in light of several past vulnerabilities and existing vulnerabilities  that may not have a fix, the plugin has switched to using a different sandbox library. A malicious actor with write access to a registered scaffolder template could manipulate the template in a way that allows for remote code execution on the scaffolder-backend instance. This was only exploitable in the template YAML definition itself and not by user input data. This is vulnerability is fixed in version 1.15.0 of `@backstage/plugin-scaffolder-backend`.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-35926?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 1.15.0 |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 1.15.0 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2023-35926?

Upgrade @backstage/plugin-scaffolder-backend to 1.15.0 or later.

## Is CVE-2023-35926 being exploited?

There is no known exploitation of CVE-2023-35926 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35926 and fix it if it is affected.

What it is: CVE-2023-35926 is a high-severity code injection vulnerability in Linuxfoundation Backstage, published on 22 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35926 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 1.15.0
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 1.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35926/ (Markdown: https://insights.sbomify.com/CVE-2023-35926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35926
- OSV: https://osv.dev/vulnerability/CVE-2023-35926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35926/
Summaries are generated and may contain mistakes; the official description above is the record.
