# CVE-2023-35930: LookupResources may return partial results in spicedb

> Attackers can bypass authorization checks by exploiting partial results in LookupResources, allowing unauthorized access to resources.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2023
- **Updated:** 6 Nov 2024
- **Also known as:** GHSA-m54h-5x5f-5m6r, GO-2023-1871

## What is CVE-2023-35930?

CVE-2023-35930 is a low-severity vulnerability in authzed spicedb, published on 26 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SpiceDB is an open source, Google Zanzibar-inspired, database system for creating and managing security-critical application permissions. Any user making a negative authorization decision based on the results of a `LookupResources` request with 1.22.0 is affected. For example, using `LookupResources` to find a list of resources to allow access to be okay: some subjects that should have access to a resource may not. But if using `LookupResources` to find a list of banned resources instead, then some users that shouldn't have access may. Generally, `LookupResources` is not and should not be to gate access in this way - that's what the `Check` API is for. Additionally, version 1.22.0 has included a warning about this bug since its initial release. Users are advised to upgrade to version 1.22.2. Users unable to upgrade should avoid using `LookupResources` for negative authorization decisions.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2023-35930?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | From 1.22.0 | 1.22.2 |
| `github.com/authzed/spicedb` | Go | From 1.22.0 | 1.22.2 |
| `github.com/authzed/spicedb` | Go | From 1.22.0 | 1.22.2 |

Products: Authzed Spicedb.

## How do I fix CVE-2023-35930?

Upgrade github.com/authzed/spicedb to 1.22.2 or later.

## Is CVE-2023-35930 being exploited?

There is no known exploitation of CVE-2023-35930 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35930 and fix it if it is affected.

What it is: CVE-2023-35930 is a low-severity vulnerability in authzed spicedb, published on 26 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-35930 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected from 1.22.0; fixed in 1.22.2
- github.com/authzed/spicedb (Go): affected from 1.22.0; fixed in 1.22.2
- github.com/authzed/spicedb (Go): affected from 1.22.0; fixed in 1.22.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35930/ (Markdown: https://insights.sbomify.com/CVE-2023-35930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35930
- OSV: https://osv.dev/vulnerability/CVE-2023-35930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35930/
Summaries are generated and may contain mistakes; the official description above is the record.
