CVE-2023-35936 Arbitrary file write is possible in Pandoc when using PDF output or --extract-media with untrusted input

Medium 6.0 Published Updated

Attackers can overwrite arbitrary files via crafted input when using PDF output or media extraction, requiring untrusted input and specific flags.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-35936?

CVE-2023-35936 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 5 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Pandoc is a Haskell library for converting from one markup format to another, and a command-line tool that uses this library. Starting in version 1.13 and prior to version 3.1.4, Pandoc is susceptible to an arbitrary file write vulnerability, which can be triggered by providing a specially crafted image element in the input when generating files using the `--extract-media` option or outputting to PDF format. This vulnerability allows an attacker to create or overwrite arbitrary files on the system ,depending on the privileges of the process running pandoc. It only affects systems that pass untrusted user input to pandoc and allow pandoc to be used to produce a PDF or with the `--extract-media` option.

The fix is to unescape the percent-encoding prior to checking that the resource is not above the working directory, and prior to extracting the extension. Some code for checking that the path is below the working directory was flawed in a similar way and has also been fixed. Note that the `--sandbox` option, which only affects IO done by readers and writers themselves, does not block this vulnerability. The vulnerability is patched in pandoc 3.1.4. As a workaround, audit the pandoc command and disallow PDF output and the `--extract-media` option.

Weakness: CWE-20

Which versions are affected by CVE-2023-35936?

1 open source package ship an affected version, including pandoc. It affects 2 products.

PackageAffectedFixed in
pandoc HackageFrom 1.133.1.4

Products include Debian Debian Linux, Pandoc Pandoc.

How do I fix CVE-2023-35936?

Upgrade pandoc to 3.1.4 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-35936 being exploited?

There is no known exploitation of CVE-2023-35936 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2023-35936, DLA-3507-1, GHSA-xj5q-fv23-575g, HSEC-2023-0014, JLSEC-2026-499, UBUNTU-CVE-2023-35936 and 1 more.

Is CVE-2023-35936 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free