{"answers":{"affected":"1 open source package ship an affected version, including pandoc. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-35936 in the wild and no public exploit code.","fix":"Upgrade pandoc to 3.1.4 or later.","what":"CVE-2023-35936 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 5 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-35936 and fix it if it is affected.\n\nWhat it is: CVE-2023-35936 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 5 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-35936 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pandoc (Hackage): affected from 1.13; fixed in 3.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-35936/ (Markdown: https://insights.sbomify.com/CVE-2023-35936/index.md)","id":"CVE-2023-35936","markdown":"https://insights.sbomify.com/CVE-2023-35936/index.md","name":"CVE-2023-35936","record":{"aliases":["DEBIAN-CVE-2023-35936","DLA-3507-1","GHSA-xj5q-fv23-575g","HSEC-2023-0014","JLSEC-2026-499","UBUNTU-CVE-2023-35936","openSUSE-SU-2024:13056-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Pandoc document converter","requires_auth":"low_privilege","summary":"Attackers can overwrite arbitrary files via crafted input when using PDF output or media extraction, requiring untrusted input and specific flags.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"pandoc","vendor":"pandoc"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Pandoc is a Haskell library for converting from one markup format to another, and a command-line tool that uses this library. Starting in version 1.13 and prior to version 3.1.4, Pandoc is susceptible to an arbitrary file write vulnerability, which can be triggered by providing a specially crafted image element in the input when generating files using the `--extract-media` option or outputting to PDF format. This vulnerability allows an attacker to create or overwrite arbitrary files on the system ,depending on the privileges of the process running pandoc. It only affects systems that pass untrusted user input to pandoc and allow pandoc to be used to produce a PDF or with the `--extract-media` option.\n\nThe fix is to unescape the percent-encoding prior to checking that the resource is not above the working directory, and prior to extracting the extension.  Some code for checking that the path is below the working directory was flawed in a similar way and has also been fixed. Note that the `--sandbox` option, which only affects IO done by readers and writers themselves, does not block this vulnerability. The vulnerability is patched in pandoc 3.1.4. As a workaround, audit the pandoc command and disallow PDF output and the `--extract-media` option.","ecosystems":["Hackage"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary file write is possible in Pandoc when using PDF output or --extract-media with untrusted input","id":"CVE-2023-35936","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"path_traversal","year":"2023"},"n_packages":1,"n_references":5,"next":{"headline":"Metersphere missing permission check","id":"CVE-2023-35937"},"packages":[{"ecosystem":"Hackage","fixed":["3.1.4"],"introduced":["1.13"],"last_affected":[],"package":"pandoc","purl":"pkg:hackage/pandoc","source":"HSEC-2023-0014"}],"prev":{"headline":"yt-dlp File Downloader cookie leak","id":"CVE-2023-35934"},"products":["pandoc"],"published":"2023-07-05","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"open","licence":"CC0 1.0","name":"Haskell Security Response Team","prefix":"HSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["jgm"]},"summary":"Attackers can overwrite arbitrary files via crafted input when using PDF output or media extraction, requiring untrusted input and specific flags.","url":"https://insights.sbomify.com/CVE-2023-35936/"}