# CVE-2023-35936: Arbitrary file write is possible in Pandoc when using PDF output or --extract-media with untrusted input

> Attackers can overwrite arbitrary files via crafted input when using PDF output or media extraction, requiring untrusted input and specific flags.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2023-35936, DLA-3507-1, GHSA-xj5q-fv23-575g, HSEC-2023-0014, JLSEC-2026-499, UBUNTU-CVE-2023-35936, openSUSE-SU-2024:13056-1

## What is CVE-2023-35936?

CVE-2023-35936 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 5 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Pandoc is a Haskell library for converting from one markup format to another, and a command-line tool that uses this library. Starting in version 1.13 and prior to version 3.1.4, Pandoc is susceptible to an arbitrary file write vulnerability, which can be triggered by providing a specially crafted image element in the input when generating files using the `--extract-media` option or outputting to PDF format. This vulnerability allows an attacker to create or overwrite arbitrary files on the system ,depending on the privileges of the process running pandoc. It only affects systems that pass untrusted user input to pandoc and allow pandoc to be used to produce a PDF or with the `--extract-media` option.

The fix is to unescape the percent-encoding prior to checking that the resource is not above the working directory, and prior to extracting the extension.  Some code for checking that the path is below the working directory was flawed in a similar way and has also been fixed. Note that the `--sandbox` option, which only affects IO done by readers and writers themselves, does not block this vulnerability. The vulnerability is patched in pandoc 3.1.4. As a workaround, audit the pandoc command and disallow PDF output and the `--extract-media` option.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-35936?

1 open source package ship an affected version, including pandoc. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pandoc` | Hackage | From 1.13 | 3.1.4 |

Products: Debian Debian Linux, Pandoc Pandoc.

## How do I fix CVE-2023-35936?

Upgrade pandoc to 3.1.4 or later.

## Is CVE-2023-35936 being exploited?

There is no known exploitation of CVE-2023-35936 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35936 and fix it if it is affected.

What it is: CVE-2023-35936 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 5 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-35936 in the wild and no public exploit code.

Affected packages and fixed versions:
- pandoc (Hackage): affected from 1.13; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35936/ (Markdown: https://insights.sbomify.com/CVE-2023-35936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35936
- OSV: https://osv.dev/vulnerability/CVE-2023-35936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35936/
Summaries are generated and may contain mistakes; the official description above is the record.
