CVE-2023-35941 Envoy vulnerable to OAuth2 credentials exploit with permanent validity
A malicious client can bypass OAuth2 authentication in Envoy proxy under specific wildcard domain configurations, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-35941?
CVE-2023-35941 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.
Weakness: CWE-116
Which versions are affected by CVE-2023-35941?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | From 1.23.0 | 1.23.12, 1.24.10, 1.25.9, 1.26.4 |
Products include Envoyproxy Envoy.
How do I fix CVE-2023-35941?
Upgrade envoy to a fixed version for your release line: 1.23.12, 1.24.10, 1.25.9 or 1.26.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-35941 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35941 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2023-35941, GHSA-7mhv-gr67-hq55.