# CVE-2023-35941: Envoy vulnerable to OAuth2 credentials exploit with permanent validity

> A malicious client can bypass OAuth2 authentication in Envoy proxy under specific wildcard domain configurations, allowing unauthorized access.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 24 Oct 2024
- **Also known as:** BIT-envoy-2023-35941, GHSA-7mhv-gr67-hq55

## What is CVE-2023-35941?

CVE-2023-35941 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2023-35941?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | From 1.23.0 | 1.23.12, 1.24.10, 1.25.9, 1.26.4 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2023-35941?

Upgrade envoy to a fixed version for your release line: 1.23.12, 1.24.10, 1.25.9 or 1.26.4.

## Is CVE-2023-35941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35941 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35941 and fix it if it is affected.

What it is: CVE-2023-35941 is a high-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35941 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected from 1.23.0; fixed in 1.23.12, 1.24.10, 1.25.9, 1.26.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35941/ (Markdown: https://insights.sbomify.com/CVE-2023-35941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35941
- OSV: https://osv.dev/vulnerability/CVE-2023-35941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35941/
Summaries are generated and may contain mistakes; the official description above is the record.
