CVE-2023-35942 Envoy's gRPC access log crash caused by the listener draining
A use-after-free vulnerability in Envoy's gRPC access logger causes a crash during listener draining, requiring specific configuration to exploit.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-35942?
CVE-2023-35942 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, gRPC access loggers using listener's global scope can cause a `use-after-free` crash when the listener is drained. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, disable gRPC access log or stop listener update.
Weakness: CWE-416
Which versions are affected by CVE-2023-35942?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | From 1.23.0 | 1.23.12, 1.24.10, 1.25.9, 1.26.4 |
Products include Envoyproxy Envoy.
How do I fix CVE-2023-35942?
Upgrade envoy to a fixed version for your release line: 1.23.12, 1.24.10, 1.25.9 or 1.26.4.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2023-35942 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35942 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2023-35942, GHSA-69vr-g55c-v2v4.