{"answers":{"affected":"1 open source package ship an affected version, including envoy. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35942 exists.","fix":"Upgrade envoy to a fixed version for your release line: 1.23.12, 1.24.10, 1.25.9 or 1.26.4.","what":"CVE-2023-35942 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-35942 and fix it if it is affected.\n\nWhat it is: CVE-2023-35942 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35942 exists.\n\nAffected packages and fixed versions:\n- envoy (Bitnami): affected from 1.23.0; fixed in 1.23.12, 1.24.10, 1.25.9, 1.26.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-35942/ (Markdown: https://insights.sbomify.com/CVE-2023-35942/index.md)","id":"CVE-2023-35942","markdown":"https://insights.sbomify.com/CVE-2023-35942/index.md","name":"CVE-2023-35942","record":{"aliases":["BIT-envoy-2023-35942","GHSA-69vr-g55c-v2v4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Envoy proxy","requires_auth":"low_privilege","summary":"A use-after-free vulnerability in Envoy's gRPC access logger causes a crash during listener draining, requiring specific configuration to exploit.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"envoy","vendor":"envoyproxy"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, gRPC access loggers using listener's global scope can cause a `use-after-free` crash when the listener is drained. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, disable gRPC access log or stop listener update.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Envoy's gRPC access log crash caused by the listener draining","id":"CVE-2023-35942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"envoyproxy:envoy","products":["envoyproxy:envoy"],"type":"use_after_free","year":"2023"},"n_packages":1,"n_references":1,"next":{"headline":"Envoy vulnerable to CORS filter segfault when origin header is removed","id":"CVE-2023-35943"},"packages":[{"ecosystem":"Bitnami","fixed":["1.23.12","1.24.10","1.25.9","1.26.4"],"introduced":["1.23.0","1.24.0","1.25.0","1.26.0"],"last_affected":[],"package":"envoy","purl":"pkg:bitnami/envoy","source":"BIT-envoy-2023-35942"}],"prev":{"headline":"Envoy vulnerable to OAuth2 credentials exploit with permanent validity","id":"CVE-2023-35941"},"products":["envoy"],"published":"2023-07-25","related":[{"cvss_score":10,"headline":"Trivial authentication bypass in Envoy","id":"CVE-2022-29226","kev_date_added":null,"published":"2022-06-09"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-18801","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2019-18802","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2020-35470","kev_date_added":null,"published":"2020-12-15"},{"cvss_score":8.6,"headline":"Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata","id":"CVE-2024-23324","kev_date_added":null,"published":"2024-02-09"},{"cvss_score":8.6,"headline":"Envoy vulnerable to OAuth2 credentials exploit with permanent validity","id":"CVE-2023-35941","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":8.6,"headline":"Incorrect handling of H2 GOAWAY + SETTINGS frames","id":"CVE-2021-39162","kev_date_added":null,"published":"2021-09-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-24","vendors":["envoyproxy"]},"summary":"A use-after-free vulnerability in Envoy's gRPC access logger causes a crash during listener draining, requiring specific configuration to exploit.","url":"https://insights.sbomify.com/CVE-2023-35942/"}