CVE-2023-35943 Envoy vulnerable to CORS filter segfault when origin header is removed
Attackers can crash Envoy proxy by removing the origin header during request processing, causing a segmentation fault and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-35943?
CVE-2023-35943 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, the CORS filter will segfault and crash Envoy when the `origin` header is removed and deleted between `decodeHeaders`and `encodeHeaders`. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, do not remove the `origin` header in the Envoy configuration.
Weakness: CWE-416
Which versions are affected by CVE-2023-35943?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | From 1.23.0 | 1.23.12, 1.24.10, 1.25.9, 1.26.4 |
Products include Envoyproxy Envoy.
How do I fix CVE-2023-35943?
Upgrade envoy to a fixed version for your release line: 1.23.12, 1.24.10, 1.25.9 or 1.26.4.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2023-35943 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35943 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2023-35943, GHSA-mc6h-6j9x-v3gq.