# CVE-2023-35943: Envoy vulnerable to CORS filter segfault when origin header is removed

> Attackers can crash Envoy proxy by removing the origin header during request processing, causing a segmentation fault and denial of service.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 24 Oct 2024
- **Also known as:** BIT-envoy-2023-35943, GHSA-mc6h-6j9x-v3gq

## What is CVE-2023-35943?

CVE-2023-35943 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, the CORS filter will segfault and crash Envoy when the `origin` header is removed and deleted between `decodeHeaders`and `encodeHeaders`. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, do not remove the `origin` header in the Envoy configuration.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2023-35943?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | From 1.23.0 | 1.23.12, 1.24.10, 1.25.9, 1.26.4 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2023-35943?

Upgrade envoy to a fixed version for your release line: 1.23.12, 1.24.10, 1.25.9 or 1.26.4.

## Is CVE-2023-35943 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35943 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35943 and fix it if it is affected.

What it is: CVE-2023-35943 is a medium-severity use after free vulnerability in Envoyproxy Envoy, published on 25 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-35943 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected from 1.23.0; fixed in 1.23.12, 1.24.10, 1.25.9, 1.26.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35943/ (Markdown: https://insights.sbomify.com/CVE-2023-35943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35943
- OSV: https://osv.dev/vulnerability/CVE-2023-35943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35943/
Summaries are generated and may contain mistakes; the official description above is the record.
