# CVE-2023-35946: Dependency cache path traversal in Gradle

> Attackers can write files outside the dependency cache or overwrite files via crafted coordinates, potentially poisoning the cache or executing code.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2023
- **Updated:** 8 Oct 2026
- **Also known as:** BELL-CVE-2023-35946, BIT-gradle-2023-35946, DEBIAN-CVE-2023-35946, GHSA-2h6c-rv6q-494v, SUSE-SU-2024:3163-1, UBUNTU-CVE-2023-35946

## What is CVE-2023-35946?

CVE-2023-35946 is a medium-severity path traversal vulnerability in gradle, published on 30 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Gradle is a build tool with a focus on build automation and support for multi-language development. When Gradle writes a dependency into its dependency cache, it uses the dependency's coordinates to compute a file location. With specially crafted dependency coordinates, Gradle can be made to write files into an unintended location. The file may be written outside the dependency cache or over another file in the dependency cache. This vulnerability could be used to poison the dependency cache or overwrite important files elsewhere on the filesystem where the Gradle process has write permissions. Exploiting this vulnerability requires an attacker to have control over a dependency repository used by the Gradle build or have the ability to modify the build's configuration. It is unlikely that this would go unnoticed. A fix has been released in Gradle 7.6.2 and 8.2 to protect against this vulnerability. Gradle will refuse to cache dependencies that have path traversal elements in their dependency coordinates. It is recommended that users upgrade to a patched version. If you are unable to upgrade to Gradle 7.6.2 or 8.2, `dependency verification` will make this vulnerability more difficult to exploit.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-35946?

1 open source package ship an affected version, including gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 7.6.2, 8.2.0 |
| `gradle` | SUSE:Linux Enterprise Module for Development Tools 15 SP5 | All versions | 4.4.1-150200.3.24.1 |
| `gradle` | SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 4.4.1-150200.3.24.1 |
| `gradle` | openSUSE:Leap 15.5 | All versions | 4.4.1-150200.3.24.1 |
| `gradle` | openSUSE:Leap 15.6 | All versions | 4.4.1-150200.3.24.1 |

Products: Gradle Gradle.

## How do I fix CVE-2023-35946?

Upgrade gradle to a fixed version for your release line: 7.6.2 or 8.2.0.

## Is CVE-2023-35946 being exploited?

There is no known exploitation of CVE-2023-35946 in the wild and no public exploit code.

## Other vulnerabilities in gradle

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-35946 and fix it if it is affected.

What it is: CVE-2023-35946 is a medium-severity path traversal vulnerability in gradle, published on 30 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-35946 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 7.6.2, 8.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-35946/ (Markdown: https://insights.sbomify.com/CVE-2023-35946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-35946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-35946
- OSV: https://osv.dev/vulnerability/CVE-2023-35946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-35946/
Summaries are generated and may contain mistakes; the official description above is the record.
