# CVE-2023-36053: Django has regular expression denial of service vulnerability in EmailValidator/URLValidator

> Attackers can cause denial of service in Django applications by submitting emails or URLs with excessive domain labels, triggering inefficient regex processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2023
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-django-2023-36053, CLSA-2026-1787036530, DEBIAN-CVE-2023-36053, DLA-3500-1, DSA-5465-1, GHSA-jh3w-4vvf-mjgr, MGASA-2023-0330, OESA-2023-1440, PYSEC-2023-100, RHSA-2024:0212, SUSE-SU-2023:3167-1, SUSE-SU-2023:3202-1, UBUNTU-CVE-2023-36053, USN-6203-1, USN-6203-2, openSUSE-SU-2023:0174-1, openSUSE-SU-2023:0176-1, openSUSE-SU-2023:0177-1, openSUSE-SU-2024:13044-1

## What is CVE-2023-36053?

CVE-2023-36053 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Django 3.2 before 3.2.20, 4 before 4.1.10, and 4.2 before 4.2.3, EmailValidator and URLValidator are subject to a potential ReDoS (regular expression denial of service) attack via a very large number of domain name labels of emails and URLs.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-36053?

8 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.20, 4.1.10, 4.2.3 |
| `django` | PyPI | From 3.2a1 | 3.2.20 |
| `django` | PyPI | From 4.0a1 | 4.1.10 |
| `django` | PyPI | From 4.2 | 4.2.3, 4.1.10, 3.2.20 |
| `django` | PyPI | From 4.2a1 | 4.2.3 |
| `Django` | PyPI | From 3.2a1 | 3.2.20 |
| `Django` | PyPI | From 4.0a1 | 4.1.10 |
| `Django` | PyPI | From 4.2a1 | 4.2.3 |
| `python-django` | Red Hat:openstack:17.1::el9 | All versions | 0:2.2.24-5.el9ost |
| `python3-django` | Red Hat:openstack:17.1::el9 | All versions | 0:2.2.24-5.el9ost |
| `python-Django` | SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.48.1 |
| `python-Django` | SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.48.1 |
| `python-Django1` | SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.47.1 |
| `python-Django` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.48.1 |
| `python-Django1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.47.1 |
| `python-Django` | SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.12.1 |
| `python-Django1` | SUSE:Package Hub 15 SP4 | All versions | 1.11.29-bp154.2.6.1 |
| `python-Django1` | SUSE:Package Hub 15 SP5 | All versions | 1.11.29-bp155.4.3.1 |
| `python-Django` | openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.12.1 |
| `python-Django1` | openSUSE:Leap 15.4 | All versions | 1.11.29-bp154.2.6.1 |
| `python-Django1` | openSUSE:Leap 15.5 | All versions | 1.11.29-bp155.4.3.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.2.3-1.1 |

Products: Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2023-36053?

Upgrade django to a fixed version for your release line: 3.2.20, 4.1.10 or 4.2.3.

## Is CVE-2023-36053 being exploited?

There is no known exploitation of CVE-2023-36053 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36053 and fix it if it is affected.

What it is: CVE-2023-36053 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36053 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.20, 4.1.10, 4.2.3
- django (PyPI): affected from 3.2a1; fixed in 3.2.20
- django (PyPI): affected from 4.0a1; fixed in 4.1.10
- django (PyPI): affected from 4.2; fixed in 4.2.3, 4.1.10, 3.2.20
- django (PyPI): affected from 4.2a1; fixed in 4.2.3
- Django (PyPI): affected from 3.2a1; fixed in 3.2.20
- Django (PyPI): affected from 4.0a1; fixed in 4.1.10
- Django (PyPI): affected from 4.2a1; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36053/ (Markdown: https://insights.sbomify.com/CVE-2023-36053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36053
- OSV: https://osv.dev/vulnerability/CVE-2023-36053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36053/
Summaries are generated and may contain mistakes; the official description above is the record.
