# CVE-2023-36237: Bagisto Cross-Site Request Forgery vulnerability

> Attackers can execute arbitrary code via CSRF in Bagisto, requiring an upgrade to secure the e-commerce platform.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-7p7q-fjfw-v3gf

## What is CVE-2023-36237?

CVE-2023-36237 is a high-severity vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Request Forgery vulnerability in Bagisto before v.1.5.1 allows an attacker to execute arbitrary code via a crafted HTML script.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-36237?

2 open source packages ship an affected version, including bagisto/bagisto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bagisto/bagisto` | Packagist | All versions | 1.3.2 |
| `bagisto/bagisto` | Packagist | All versions | 1.3.2 |

Products: Webkul Bagisto.

## How do I fix CVE-2023-36237?

Upgrade bagisto/bagisto to 1.3.2 or later.

## Is CVE-2023-36237 being exploited?

There is no known exploitation of CVE-2023-36237 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-21448](https://insights.sbomify.com/CVE-2026-21448/): Bagisto has Normal & Blind SSTI from low-privilege user when ordering product (high 8.9)
- [CVE-2026-21446](https://insights.sbomify.com/CVE-2026-21446/): Bagisto Missing Authentication on Installer API Endpoints (high 8.8)
- [CVE-2023-33570](https://insights.sbomify.com/CVE-2023-33570/): Code injection in n/a (high 8.8)
- [CVE-2019-16403](https://insights.sbomify.com/CVE-2019-16403/): Authorization Bypass Through User-Controlled Key in Bagisto (high 8.8)
- [CVE-2019-14933](https://insights.sbomify.com/CVE-2019-14933/): Bagisto CSRF Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36237 and fix it if it is affected.

What it is: CVE-2023-36237 is a high-severity vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-36237 in the wild and no public exploit code.

Affected packages and fixed versions:
- bagisto/bagisto (Packagist): affected all versions; fixed in 1.3.2
- bagisto/bagisto (Packagist): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36237/ (Markdown: https://insights.sbomify.com/CVE-2023-36237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36237
- OSV: https://osv.dev/vulnerability/CVE-2023-36237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36237/
Summaries are generated and may contain mistakes; the official description above is the record.
