# CVE-2023-36260: Craft CMS Feed-Me

> Remote attackers can cause denial of service in the Feed Me plugin for Craft CMS by submitting crafted strings to specific fields.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 18 Oct 2024
- **Also known as:** GHSA-6p78-f7h9-6838

## What is CVE-2023-36260?

CVE-2023-36260 is a high-severity denial of service vulnerability in Craftcms Craft Cms, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the Feed Me plugin 4.6.1 for Craft CMS. It allows remote attackers to cause a denial of service (DoS) via crafted strings to Feed-Me Name and Feed-Me URL fields, due to saving a feed using an Asset element type with no volume selected. NOTE: this is not a report about code provided by the Craft CMS product; it is only a report about the Feed Me plugin. NOTE: a third-party report states that commit b5d6ede51848349bd91bc95fec288b6793f15e28 has "nothing to do with security."

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-36260?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | All versions | 4.6.2 |
| `craftcms/cms` | Packagist | All versions | 4.6.2 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2023-36260?

Upgrade craftcms/cms to 4.6.2 or later.

## Is CVE-2023-36260 being exploited?

There is no known exploitation of CVE-2023-36260 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36260 and fix it if it is affected.

What it is: CVE-2023-36260 is a high-severity denial of service vulnerability in Craftcms Craft Cms, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36260 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected all versions; fixed in 4.6.2
- craftcms/cms (Packagist): affected all versions; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36260/ (Markdown: https://insights.sbomify.com/CVE-2023-36260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36260
- OSV: https://osv.dev/vulnerability/CVE-2023-36260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36260/
Summaries are generated and may contain mistakes; the official description above is the record.
