# CVE-2023-36388: Apache Superset: Improper API permission for low privilege users allows for SSRF

> Authenticated low-privilege users can exploit improper API permissions to perform Server-Side Request Forgery attacks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** BIT-superset-2023-36388, GHSA-4fg9-5w46-xmrj, PYSEC-2026-1159

## What is CVE-2023-36388?

CVE-2023-36388 is a medium-severity server-side request forgery vulnerability in Apache Superset, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper REST API permission in Apache Superset up to and including 2.1.0 allows for an authenticated Gamma users to test network connections, possible SSRF.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-36388?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions to 2.1.0 | None |
| `apache-superset` | PyPI | All versions to 2.1.0 | None |
| `apache-superset` | PyPI | All versions | 2.1.1 |
| `superset` | Bitnami | All versions | 2.1.1 |

Products: Apache Superset.

## How do I fix CVE-2023-36388?

Upgrade apache-superset to 2.1.1 or later.

## Is CVE-2023-36388 being exploited?

There is no known exploitation of CVE-2023-36388 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36388 and fix it if it is affected.

What it is: CVE-2023-36388 is a medium-severity server-side request forgery vulnerability in Apache Superset, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36388 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions up to 2.1.0; no fix listed
- apache-superset (PyPI): affected all versions up to 2.1.0; no fix listed
- apache-superset (PyPI): affected all versions; fixed in 2.1.1
- superset (Bitnami): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36388/ (Markdown: https://insights.sbomify.com/CVE-2023-36388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36388
- OSV: https://osv.dev/vulnerability/CVE-2023-36388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36388/
Summaries are generated and may contain mistakes; the official description above is the record.
