# CVE-2023-36456: Authentik lacks Proxy IP headers validation

> Attackers can spoof IP addresses in Authentik logs and bypass IP-based security policies when the service is directly accessible without a reverse proxy.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2023
- **Updated:** 14 Nov 2024
- **Also known as:** BIT-authentik-2023-36456, GHSA-cmxp-jcw7-jjjv

## What is CVE-2023-36456?

CVE-2023-36456 is a high-severity vulnerability in goauthentik authentik, published on 6 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source Identity Provider. Prior to versions 2023.4.3 and 2023.5.5, authentik does not verify the source of the X-Forwarded-For and X-Real-IP headers, both in the Python code and the go code. Only authentik setups that are directly accessible by users without a reverse proxy are susceptible to this. Possible spoofing of IP addresses in logs, downstream applications proxied by (built in) outpost, IP bypassing in custom flows if used.

This poses a possible security risk when someone has flows or policies that check the user's IP address, e.g. when they want to ignore the user's 2 factor authentication when the user is connected to the company network. A second security risk is that the IP addresses in the logfiles and user sessions are not reliable anymore. Anybody can spoof this address and one cannot verify that the user has logged in from the IP address that is in their account's log. A third risk is that this header is passed on to the proxied application behind an outpost. The application may do any kind of verification, logging, blocking or rate limiting based on the IP address, and this IP address can be overridden by anybody that want to.

Versions 2023.4.3 and 2023.5.5 contain a patch for this issue.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2023-36456?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2023.4.3, 2023.5.5 |

Products: Goauthentik Authentik.

## How do I fix CVE-2023-36456?

Upgrade authentik to a fixed version for your release line: 2023.4.3 or 2023.5.5.

## Is CVE-2023-36456 being exploited?

There is no known exploitation of CVE-2023-36456 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36456 and fix it if it is affected.

What it is: CVE-2023-36456 is a high-severity vulnerability in goauthentik authentik, published on 6 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36456 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2023.4.3, 2023.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36456/ (Markdown: https://insights.sbomify.com/CVE-2023-36456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36456
- OSV: https://osv.dev/vulnerability/CVE-2023-36456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36456/
Summaries are generated and may contain mistakes; the official description above is the record.
