# CVE-2023-36464: Infinite Loop when a comment isn't followed by a character in pypdf

> An attacker can cause a denial of service via infinite loop in pypdf by crafting a specific PDF file that triggers the vulnerability during text extraction.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2023
- **Updated:** 3 Dec 2024
- **Also known as:** DEBIAN-CVE-2023-36464, GHSA-4vvm-4w3v-6mr8, PYSEC-2026-1835, PYSEC-2026-3008, RHLW-2026-821eaab8409c2a61, ROOT-APP-PYPI-CVE-2023-36464, UBUNTU-CVE-2023-36464

## What is CVE-2023-36464?

CVE-2023-36464 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 27 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pypdf is an open source, pure-python PDF library. In affected versions an attacker may craft a PDF which leads to an infinite loop if `__parse_content_stream` is executed. That is, for example, the case if the user extracted text from such a PDF. This issue was introduced in pull request #969 and resolved in pull request #1828. Users are advised to upgrade. Users unable to upgrade may modify the line `while peek not in (b"\r", b"\n")` in `pypdf/generic/_data_structures.py` to `while peek not in (b"\r", b"\n", b"")`.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2023-36464?

6 open source packages ship an affected version, including pypdf, PyPDF2 and pypdf2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | From 3.1.0 | 3.9.0 |
| `pypdf` | PyPI | From 3.1.0 | 3.9.0 |
| `pypdf` | PyPI | From 3.1.0 | 3.9.0 |
| `PyPDF2` | PyPI | From 2.2.0 to 3.0.1 | None |
| `pypdf2` | PyPI | From 2.2.0 to 3.0.1 | None |
| `pypdf2` | PyPI | From 2.2.0 | 3.9.0 |

Products: Pypdf2 Project Pypdf2, Pypdf Project Pypdf.

## How do I fix CVE-2023-36464?

Upgrade pypdf to 3.9.0 or later.

## Is CVE-2023-36464 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36464 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36464 and fix it if it is affected.

What it is: CVE-2023-36464 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 27 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36464 exists.

Affected packages and fixed versions:
- pypdf (PyPI): affected from 3.1.0; fixed in 3.9.0
- pypdf (PyPI): affected from 3.1.0; fixed in 3.9.0
- pypdf (PyPI): affected from 3.1.0; fixed in 3.9.0
- PyPDF2 (PyPI): affected from 2.2.0 up to 3.0.1; no fix listed
- pypdf2 (PyPI): affected from 2.2.0 up to 3.0.1; no fix listed
- pypdf2 (PyPI): affected from 2.2.0; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36464/ (Markdown: https://insights.sbomify.com/CVE-2023-36464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36464
- OSV: https://osv.dev/vulnerability/CVE-2023-36464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36464/
Summaries are generated and may contain mistakes; the official description above is the record.
