CVE-2023-36468 Upgrading doesn't prevent exploiting vulnerable XWiki documents
Attackers can execute arbitrary code by accessing vulnerable old document revisions after upgrading XWiki, bypassing security fixes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-36468?
CVE-2023-36468 is a critical code injection vulnerability in Xwiki Xwiki, published on 29 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an XWiki installation is upgraded and that upgrade contains a fix for a bug in a document, just a new version of that document is added. In some cases, it's still possible to exploit the vulnerability that was fixed in the new version. The severity of this depends on the fixed vulnerability, for the purpose of this advisory take CVE-2022-36100/GHSA-2g5c-228j-p52x as example - it is easily exploitable with just view rights and critical. When XWiki is upgraded from a version before the fix for it (e.g., 14.3) to a version including the fix (e.g., 14.4), the vulnerability can still be reproduced by adding `rev=1.1` to the URL used in the reproduction steps so remote code execution is possible even after upgrading. Therefore, this affects the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability also affects manually added script macros that contained security vulnerabilities that were later fixed by changing the script macro without deleting the versions with the security vulnerability from the history. This vulnerability doesn't affect freshly installed versions of XWiki. Further, this vulnerability doesn't affect content that is only loaded from the current version of a document like the code of wiki macros or UI extensions. This vulnerability has been patched in XWiki 14.10.7 and 15.2RC1 by forcing old revisions to be executed in a restricted mode that disables all script macros. As a workaround, admins can manually delete old revisions of affected documents. A script could be used to identify all installed documents and delete the history for them. However, also manually added and later corrected code may be affected by this vulnerability so it is easy to miss documents.
Weakness: CWE-459
Which versions are affected by CVE-2023-36468?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.2-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.2-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 2.0 | 14.10.7 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 2.0 | 14.10.7 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-36468?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.2-rc-1 or 14.10.7.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-36468 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36468 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-8q9q-r9v2-644m.