# CVE-2023-36472: Strapi may leak sensitive user information, user reset password, tokens via content-manager views

> Unauthorized users with view permissions can access sensitive password reset tokens and private fields via the content-manager relations route.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-v8gg-4mq2-88q4

## What is CVE-2023-36472?

CVE-2023-36472 is a medium-severity vulnerability in strapi, published on 15 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Strapi is an open-source headless content management system. Prior to version 4.11.7, an unauthorized actor can get access to user reset password tokens if they have the configure view permissions. The `/content-manager/relations` route does not remove private fields or ensure that they can't be selected. This issue is fixed in version 4.11.7.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-36472?

6 open source packages ship an affected version, including @strapi/admin, @strapi/plugin-content-manager and @strapi/utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/admin` | npm | All versions | 4.11.7 |
| `@strapi/admin` | npm | All versions | 4.11.7 |
| `@strapi/plugin-content-manager` | npm | All versions | 4.11.7 |
| `@strapi/plugin-content-manager` | npm | All versions | 4.11.7 |
| `@strapi/utils` | npm | All versions | 4.11.7 |
| `@strapi/utils` | npm | All versions | 4.11.7 |

Products: Strapi Strapi.

## How do I fix CVE-2023-36472?

Upgrade @strapi/admin to 4.11.7 or later.

## Is CVE-2023-36472 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36472 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36472 and fix it if it is affected.

What it is: CVE-2023-36472 is a medium-severity vulnerability in strapi, published on 15 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-36472 exists.

Affected packages and fixed versions:
- @strapi/admin (npm): affected all versions; fixed in 4.11.7
- @strapi/admin (npm): affected all versions; fixed in 4.11.7
- @strapi/plugin-content-manager (npm): affected all versions; fixed in 4.11.7
- @strapi/plugin-content-manager (npm): affected all versions; fixed in 4.11.7
- @strapi/utils (npm): affected all versions; fixed in 4.11.7
- @strapi/utils (npm): affected all versions; fixed in 4.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36472/ (Markdown: https://insights.sbomify.com/CVE-2023-36472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36472
- OSV: https://osv.dev/vulnerability/CVE-2023-36472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36472/
Summaries are generated and may contain mistakes; the official description above is the record.
