# CVE-2023-36475: Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution

> An attacker can achieve remote code execution in Parse Server by exploiting prototype pollution in the MongoDB BSON parser.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2023
- **Updated:** 27 Nov 2024
- **Also known as:** BIT-parse-2023-36475, GHSA-462x-c3jw-7vr6

## What is CVE-2023-36475?

CVE-2023-36475 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 28 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 5.5.2 and 6.2.1, an attacker can use a prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser. A patch is available in versions 5.5.2 and 6.2.1.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-36475?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 5.5.2 |
| `parse-server` | npm | All versions | 5.5.2 |
| `parse-server` | npm | From 6.0.0 | 6.2.1 |
| `parse-server` | npm | From 6.0.0 | 6.2.1 |
| `parse` | Bitnami | All versions | 5.5.2, 6.2.1 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2023-36475?

Upgrade parse-server to a fixed version for your release line: 5.5.2 or 6.2.1.

## Is CVE-2023-36475 being exploited?

There is no known exploitation of CVE-2023-36475 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2022-39396](https://insights.sbomify.com/CVE-2022-39396/): Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36475 and fix it if it is affected.

What it is: CVE-2023-36475 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 28 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-36475 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 5.5.2
- parse-server (npm): affected all versions; fixed in 5.5.2
- parse-server (npm): affected from 6.0.0; fixed in 6.2.1
- parse-server (npm): affected from 6.0.0; fixed in 6.2.1
- parse (Bitnami): affected all versions; fixed in 5.5.2, 6.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36475/ (Markdown: https://insights.sbomify.com/CVE-2023-36475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36475
- OSV: https://osv.dev/vulnerability/CVE-2023-36475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36475/
Summaries are generated and may contain mistakes; the official description above is the record.
