CVE-2023-36477 Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform
Users with edit rights can inject malicious JavaScript into CKEditor configuration, leading to persistent XSS and potential service disruption.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-36477?
CVE-2023-36477 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights can edit all pages in the `CKEditor' space. This makes it possible to perform a variety of harmful actions, such as removing technical documents, leading to loss of service and editing the javascript configuration of CKEditor, leading to persistent XSS. This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Users are advised to upgrade. Users unable to upgrade may manually address the issue by restricting the `edit` and `delete` rights to a trusted user or group (e.g. the `XWiki.XWikiAdminGroup` group), implicitly disabling those rights for all other users. See commit `9d9d86179` for details.
Weakness: CWE-79
Which versions are affected by CVE-2023-36477?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-ckeditor-ui and org.xwiki.contrib:application-ckeditor-ui. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-ckeditor-ui Maven | From 14.6-rc-1 | 14.10.6 |
org.xwiki.platform:xwiki-platform-ckeditor-ui Maven | From 14.6-rc-1 | 14.10.6 |
org.xwiki.platform:xwiki-platform-ckeditor-ui Maven | From 15.0-rc-1 | 15.1 |
org.xwiki.platform:xwiki-platform-ckeditor-ui Maven | From 15.0-rc-1 | 15.1 |
org.xwiki.contrib:application-ckeditor-ui Maven | From 1.9 | 1.64.9 |
org.xwiki.contrib:application-ckeditor-ui Maven | From 1.9 | 1.64.9 |
Products include Xwiki Ckeditor Integration, Xwiki Xwiki.
How do I fix CVE-2023-36477?
Upgrade org.xwiki.platform:xwiki-platform-ckeditor-ui to a fixed version for your release line: 14.10.6 or 15.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-36477 being exploited?
There is no known exploitation of CVE-2023-36477 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
Sources
Also known as GHSA-793w-g325-hrw2.