{"answers":{"affected":"6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-ckeditor-ui and org.xwiki.contrib:application-ckeditor-ui. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-36477 in the wild and no public exploit code.","fix":"Upgrade org.xwiki.platform:xwiki-platform-ckeditor-ui to a fixed version for your release line: 14.10.6 or 15.1.","what":"CVE-2023-36477 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-36477 and fix it if it is affected.\n\nWhat it is: CVE-2023-36477 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-36477 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 14.6-rc-1; fixed in 14.10.6\n- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 14.6-rc-1; fixed in 14.10.6\n- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 15.0-rc-1; fixed in 15.1\n- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 15.0-rc-1; fixed in 15.1\n- org.xwiki.contrib:application-ckeditor-ui (Maven): affected from 1.9; fixed in 1.64.9\n- org.xwiki.contrib:application-ckeditor-ui (Maven): affected from 1.9; fixed in 1.64.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-36477/ (Markdown: https://insights.sbomify.com/CVE-2023-36477/index.md)","id":"CVE-2023-36477","markdown":"https://insights.sbomify.com/CVE-2023-36477/index.md","name":"CVE-2023-36477","record":{"aliases":["GHSA-793w-g325-hrw2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki Platform","requires_auth":"low_privilege","summary":"Users with edit rights can inject malicious JavaScript into CKEditor configuration, leading to persistent XSS and potential service disruption.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor_integration","vendor":"xwiki"},{"product":"xwiki","vendor":"xwiki"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights can edit all pages in the `CKEditor' space. This makes it possible to perform a variety of harmful actions, such as removing technical documents, leading to loss of service and editing the javascript configuration of CKEditor, leading to persistent XSS. This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Users are advised to upgrade. Users unable to upgrade may manually address the issue by restricting the `edit` and `delete` rights to a trusted user or group (e.g. the `XWiki.XWikiAdminGroup` group), implicitly disabling those rights for all other users. See commit `9d9d86179` for details.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform","id":"CVE-2023-36477","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"xwiki:xwiki","products":["xwiki:xwiki"],"type":"xss","year":"2023"},"n_packages":6,"n_references":4,"next":{"headline":"HTTP/2 HPACK integer overflow and buffer allocation","id":"CVE-2023-36478"},"packages":[{"ecosystem":"Maven","fixed":["1.64.9"],"introduced":["1.9"],"last_affected":[],"package":"org.xwiki.contrib:application-ckeditor-ui","purl":null,"source":"GHSA-793w-g325-hrw2"},{"ecosystem":"Maven","fixed":["1.64.9"],"introduced":["1.9"],"last_affected":[],"package":"org.xwiki.contrib:application-ckeditor-ui","purl":"pkg:maven/org.xwiki.contrib/application-ckeditor-ui","source":"GHSA-793w-g325-hrw2"},{"ecosystem":"Maven","fixed":["14.10.6"],"introduced":["14.6-rc-1"],"last_affected":[],"package":"org.xwiki.platform:xwiki-platform-ckeditor-ui","purl":null,"source":"GHSA-793w-g325-hrw2"},{"ecosystem":"Maven","fixed":["14.10.6"],"introduced":["14.6-rc-1"],"last_affected":[],"package":"org.xwiki.platform:xwiki-platform-ckeditor-ui","purl":"pkg:maven/org.xwiki.platform/xwiki-platform-ckeditor-ui","source":"GHSA-793w-g325-hrw2"},{"ecosystem":"Maven","fixed":["15.1"],"introduced":["15.0-rc-1"],"last_affected":[],"package":"org.xwiki.platform:xwiki-platform-ckeditor-ui","purl":null,"source":"GHSA-793w-g325-hrw2"},{"ecosystem":"Maven","fixed":["15.1"],"introduced":["15.0-rc-1"],"last_affected":[],"package":"org.xwiki.platform:xwiki-platform-ckeditor-ui","purl":"pkg:maven/org.xwiki.platform/xwiki-platform-ckeditor-ui","source":"GHSA-793w-g325-hrw2"}],"prev":{"headline":"`calamares-nixos-extensions` LUKS keyfile exposure","id":"CVE-2023-36476"},"products":["xwiki-platform"],"published":"2023-06-30","related":[{"cvss_score":9.1,"headline":"org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery","id":"CVE-2023-22457","kev_date_added":null,"published":"2023-01-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-12-04","vendors":["xwiki"]},"summary":"Users with edit rights can inject malicious JavaScript into CKEditor configuration, leading to persistent XSS and potential service disruption.","url":"https://insights.sbomify.com/CVE-2023-36477/"}