# CVE-2023-36477: Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform

> Users with edit rights can inject malicious JavaScript into CKEditor configuration, leading to persistent XSS and potential service disruption.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2023
- **Updated:** 4 Dec 2024
- **Also known as:** GHSA-793w-g325-hrw2

## What is CVE-2023-36477?

CVE-2023-36477 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights can edit all pages in the `CKEditor' space. This makes it possible to perform a variety of harmful actions, such as removing technical documents, leading to loss of service and editing the javascript configuration of CKEditor, leading to persistent XSS. This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Users are advised to upgrade. Users unable to upgrade may manually address the issue by restricting the `edit` and `delete` rights to a trusted user or group (e.g. the `XWiki.XWikiAdminGroup` group), implicitly disabling those rights for all other users. See commit `9d9d86179` for details.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-36477?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-ckeditor-ui and org.xwiki.contrib:application-ckeditor-ui. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-ckeditor-ui` | Maven | From 14.6-rc-1 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-ckeditor-ui` | Maven | From 14.6-rc-1 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-ckeditor-ui` | Maven | From 15.0-rc-1 | 15.1 |
| `org.xwiki.platform:xwiki-platform-ckeditor-ui` | Maven | From 15.0-rc-1 | 15.1 |
| `org.xwiki.contrib:application-ckeditor-ui` | Maven | From 1.9 | 1.64.9 |
| `org.xwiki.contrib:application-ckeditor-ui` | Maven | From 1.9 | 1.64.9 |

Products: Xwiki Ckeditor Integration, Xwiki Xwiki.

## How do I fix CVE-2023-36477?

Upgrade org.xwiki.platform:xwiki-platform-ckeditor-ui to a fixed version for your release line: 14.10.6 or 15.1.

## Is CVE-2023-36477 being exploited?

There is no known exploitation of CVE-2023-36477 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2023-22457](https://insights.sbomify.com/CVE-2023-22457/): org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-36477 and fix it if it is affected.

What it is: CVE-2023-36477 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 30 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-36477 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 14.6-rc-1; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 14.6-rc-1; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 15.0-rc-1; fixed in 15.1
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): affected from 15.0-rc-1; fixed in 15.1
- org.xwiki.contrib:application-ckeditor-ui (Maven): affected from 1.9; fixed in 1.64.9
- org.xwiki.contrib:application-ckeditor-ui (Maven): affected from 1.9; fixed in 1.64.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-36477/ (Markdown: https://insights.sbomify.com/CVE-2023-36477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-36477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-36477
- OSV: https://osv.dev/vulnerability/CVE-2023-36477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-36477/
Summaries are generated and may contain mistakes; the official description above is the record.
